
Getting started with STM32WL5x MCUs using IAR Embedded Workbench® and MDK-ARM	 AN5556

Начало работы с микроконтроллерами STM32WL5x с использованием 
IAR Embedded Workbench® и MDK-ARM

Вступление
В этом документе приведены рекомендации по использованию программ-

ных инструментальных средств IAR Embedded Workbench® for Arm® (EWARM) и 
MDK-ARM от Keil® с двухъядерными микроконтроллерами (MCU) STM32WL5x.

1 Предпосылки
Перед началом этого руководства необходимо установить следующие инстру-

менты:
• EWARM IDE доступна для загрузки с официального веб-сайта IAR System®.
• MDK-ARM IDE доступна для загрузки с официального веб-сайта Arm® Keil®.
• STM32CubeProgrammer (STM32CubeProg) доступен для загрузки с офици-

ального веб-сайта ST
• Пакет MCU STM32CubeWL доступен для загрузки с официального веб-сайта ST
• Сервер ST-LINK доступен для загрузки с официального веб-сайта ST.
Перечисленные ниже документы также могут помочь:
• Справочное руководство STM32WL5x (RM0453)
• STM32WL55xx STM32WL54xx техническое описание (DS13293)
• Технические справочные руководства Cortex®-M4 и M0 + (доступны на веб-

сайте Arm®)
Примечание. Arm является зарегистрированным товарным знаком Arm Limited 

(или ее дочерних компаний) в США и / или в других странах.

2 Архитектура STM32WL5x
Двухъядерные микроконтроллеры STM32WL5x используют архитектуру ге-

терогенного ядра, которая состоит из ядра Cortex-M4 (с именем CPU1) и ядра 
Cortex-M0 + (с именем CPU2).

Эти два ядра всегда загружаются отдельно. Двухъядерная отладка позволяет 
одновременно отлаживать оба ядра с помощью одного аппаратного отладочного 
зонда.

2.1 Порт доступа
Устройства содержат два порта доступа (AP):
• AP0: порт доступа отладки CPU1 (AHB-AP)
• AP1: порт доступа отладки CPU2 (AHB-AP)

2.2 Загрузка CPU2
CPU2 загружается после того, как CPU1 установил бит C2BOOT в регистре 

управления мощностью 4 (PWR_CR4). Значение C2BOOT сохраняется в режиме 
ожидания, и CPU2 загружается соответствующим образом при выходе из режима 
ожидания. Когда защита включена с помощью байта опции, CPU2 также загру-
жается при обнаружении незаконного доступа. CPU2 может загружаться из си-
стемной памяти (RSS / SFI) или из любого места пользовательской флэш-памяти 
(0x0800 0000), SRAM1 (0x2000 0000) или SRAM2 (0x2000 8000).
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2.3 Поддержка отладки
На рисунке ниже показано логическое разделение инфраструктуры отладки с 

двумя интерфейсами: последовательный провод и порт отладки JTAG.

Рисунок 1. Блок-схема инфраструктуры поддержки отладки.

Таблица 1. Функции отладки ядер Cortex-M
CPU1 (Cortex-M4) CPU2 (Cortex-M0 +)

• Таблица ROM • Таблица ROM

• Пространство управления системой (SCS) • Пространство управления системой (SCS)

• Блок точки останова (FPB) • Блок точки останова (FPB)

• Точка наблюдения и отслеживание данных (DWT) • Точка наблюдения и отслеживание данных (DWT)

• Макроячейка инструментальной трассировки (ITM) • Интерфейс перекрестного запуска (CTI)

• Интерфейсный блок порта трассировки (TPIU)

• Интерфейс перекрестного запуска (CTI)
Функции отладки на уровне устройства управляются регистрами DBGMCU, 

доступными только для CPU1.

2.4 Интерфейс кросс-триггера (CTI)
В STM32WL5x есть два компонента CTI: один предназначен для CPU1, а дру-

гой - для CPU2. Эти CTI связаны друг с другом через матрицу перекрестного за-
пуска (CTM), и они позволяют событиям из различных источников запускать от-
ладочную активность.

Например, точка останова, достигнутая в одном из ядер процессора, может 
остановить другой процессор.
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2.5 Глобальный контроллер безопасности (GTZC)
Устройства STM32WL5x поддерживают безопасность с изоляцией между:
• безопасный мир, управляемый CPU2, где обычно запускаются приложения, 

чувствительные к безопасности, и расположены критические ресурсы
• небезопасный или общедоступный мир, обрабатываемый ЦП1, в котором 

используются незащищенные транзакции

2.6 Безопасная конфигурация (биты опций ESE / FSD)
Вся или часть флэш-памяти и памяти SRAM1, SRAM2 может быть сделана за-

щищенной, доступной исключительно для чтения и записи защищенным веду-
щим устройством: каналы CPU2 и DMA (которые были настроены как защищен-
ные). Защищенный CPU2 может работать только из защищенных областей, тогда 
как CPU1 может работать только из незащищенных областей.

Примечание. Защита CPU2 включается, когда часть или вся флэш-память за-
щищена (FSD = 0) или когда загрузка байта опции не выполняется. В этом случае 
установлен бит ESE в FLASH_OPTR.

Измените режим безопасности CPU2
Безопасность CPU2 легко включить, загрузив в пользовательскую опцию FSD 

значение 0 (безопасность применяется на любом уровне RDP). Защищенный на-
чальный адрес CPU2 может быть изменен защищенным CPU2 путем загрузки но-
вой пользовательской опции SFSA. Чтобы полностью отключить защиту, CPU2 
устанавливает бит FSD в 1.
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Примечание. Перед снятием защиты с части или всей памяти рекомендуется 
стереть страницу с той части флэш-памяти, которая становится небезопасной. 
И незащищенный CPU1, и защищенный CPU2 могут снять защиту, сбросив бит ESE 
в 0 в FLASH_OPTR и регрессив уровень RDP с уровня 1 на уровень 0. В этом случае 
регистры резервного копирования основной флэш-памяти (RTC_BKPxR), SRAM1, 
SRAM2 и PKA SRAM стираются. Безопасная область флэш-памяти Безопасная 
область флэш-памяти имеет сектор размером 2 Кбайта и определяется пользова-
тельской опцией безопасного начального адреса флэш-памяти, управляемой из SFSA 
[6: 0] в FLASH_SFR. В том же регистре бит FSD определяет, включена ли защита 
флэш-памяти. При включении активируется вся система безопасности системы.

Безопасные области SRAM
Области SRAM1 и SRAM2 защищены только тогда, когда включена защита 

флэш-памяти (ESE = 1 и FSD = 0).
Защищенные области SRAM1 и SRAM2 имеют гранулярность 1 Кбайт. Ре-

зервная SRAM2 может быть сконфигурирована как защищенная с помощью бита 
BRSD и ее начального адреса из SBRSA [4: 0] в FLASG_SRRVR. Не резервная 
SRAM может быть настроена как защищенная с помощью бита NBRSD и ее на-
чального адреса из SNBRSA [4: 0] в FLASG_SRRVR.

Отладочный доступ
Выбор доступа для отладки CPU2 не зависит от безопасности:
• Когда система небезопасна (ESE = 0), CPU1 и CPU2 могут включать и от-

ключать отладочный доступ CPU2 через бит DDS в FLASH_SFR. В этом случае 
бит C2SWDBGEN недоступен для записи, и его значение по умолчанию - отладка 
включена. Отладка CPU2 DDS включается / выключается после перезапуска OBL.

• Когда система защищена (ESE = 1), доступ к отладке CPU2 может быть разре-
шен только защищенным CPU2 через биты DDS и C2SWDBGEN. Отладка CPU2 
может быть отключена непосредственно CPU2 через бит DDS и косвенно обоими 
процессорами при регрессии ESE. Отладка CPU2 включается / выключается по-
сле перезапуска OBL.

3 Использование EWARM
EWARM (IAR Embedded Workbench for Arm) по умолчанию устанавливается в 

папку C: \ Program Files (x86) \ IAR Systems.
Двухъядерные устройства STM32WL5x официально поддерживаются (без пат-

чей ST) на EWARM, начиная с версии 8.50.9.
В этом разделе используется EWARM v8.50.6 с внутренним патчем для 

STM32WL5x (EWARMv8_STM32WLxx_V4.7) и шаблон проекта из STM32Cube_
FW_WL_V1.0.0.

3.1 Двухъядерные шаги отладки (EWARM)

3.1.1 Настройки проекта CM4 (EWARM)
В этом разделе описаны настройки проекта CM4 и используется шаблон про-

екта из STM32Cube_FW_WL_V1.0.0 с именем Templates_CM4.
1. Откройте проект Template DualCore в

\ STM32Cube_FW_WL_V1.0.0 \ Проекты \ NUCLEO-WL55JC \ Templates \ DualCore \ EWARM.
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Этот проект используется для одновременной работы с обоими ядрами. Этот 
проект теперь отображается в представлении Project Explorer, как показано на ри-
сунке ниже.

2. Установите проект Templates_CM4 как активный и убедитесь, что настройки 
совместимы с опциями проекта ниже.

a. Перейдите в Project > Options. В общих параметрах выберите устройство 
STM32WL55JC_M4 (см. Рисунок ниже)
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b. Перейдите на вкладку  Linker -> Config Linker configuration file editor section. Щелкни-
те Edit, чтобы отобразить редактор файла конфигурации компоновщика. Убедитесь, 
что приложение связано с правильным адресом: загрузка из основной флэш-памяти 
по адресу 0x0800 0000 и загрузка из памяти SRAM по адресу 0x2000 0000.
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c. На вкладке Debugger выберите ST-LINK в качестве отладчика в поле «Драй-
вер» (плата NUCLEO ‑ WL55JC содержит встроенный отладчик STLINK-V3).

d. Перейдите на вкладку Debugger -> Download и установите флажок «Использо-
вать загрузчик флэш-памяти».

е. Перейдите в Project -> Options -> ST-LINK -> Setup.

f. Выберите Access Port (порт доступа):
- Авто: порт доступа 0 для Cortex-M4 используется автоматически.
- Вручную: порт доступа можно выбрать вручную (например, поставив 0 с по-

мощью CM4).
g. Выберите SWD в интерфейсе связи, чтобы использовать канал связи после-

довательного вывода (SWO) (меньше контактов, чем JTAG).
h. Выберите Reset type (тип сброса): Connect during reset  (при подключении во время 

сброса) ST-LINK подключается к цели, сохраняя активным сброс. Сброс выполня-
ется на низком уровне и остается на низком уровне при подключении к цели.
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i. Перейдите на вкладку Multicore, чтобы включить использование общего ре-
жима для одновременной отладки обоих ядер.

Примечание. Чтобы настроить многоядерную отладку с помощью зонда отладки 
ST-LINK, установите последнюю версию сервера ST-LINK, доступную на www.st.com.

3.1.2 Настройки проекта CM0 + (EWARM)
В этом разделе описаны настройки проекта CM0 + и используется шаблон про-

екта из STM32Cube_FW_WL_V1.0.0 с именем Templates_CM0PLUS.
Важно:
CPU2 (Cortex-M0 +) загружается после того, как CPU1 (Cortex-M4) установил 

бит C2BOOT в регистре управления мощностью 4 (PWR_CR4). Это позволяет 
CPU1 инициализировать систему после сброса или выхода из режима понижен-
ного энергопотребления системы перед загрузкой CPU2.

1. Откройте в другом экземпляре проект Templates_CM0PLUS в
\ STM32Cube_FW_WL_V1.0.0 \ Projects \ NUCLEO-WL55JC \ Templates \ DualCore \ EWARM, 

и убедитесь, что настройки совместимы с параметрами, указанными ниже.
a. Перейдите в Project -> Options. В общих параметрах выберите устройство 

STM32WL55JC_M0 + (см. Рисунок ниже).
b. Перейдите на вкладку  Linker tab -> Config Linker configuration file editor section. 

Щелкните Изменить, чтобы отобразить редактор файла конфигурации компонов-
щика. Убедитесь, что приложение было связано с правильным адресом: загрузка 
из основной флэш-памяти по адресу 0x0802 0000 и загрузка из памяти SRAM по 
адресу 0x2000 4000

c. На вкладке Debugger tab выберите ST-LINK в качестве отладчика в поле «Драй-
вер».

d. Перейдите Debugger -> Download tab and tick the Use flash loader(s) check box (вклад-
ка «Скачать» и установите флажок Использовать флеш-загрузчик (и).

е. Перейдите в Project -> Options -> ST-LINK -> Setup.
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f. Выберите порт доступа:
- Авто: порт доступа 1 для Cortex-M0 + используется автоматически.
- Вручную: можно выбрать порт доступа вручную (например, поставив 1 с CM0 +).
g. Выберите SWD в интерфейсе связи, чтобы использовать канал связи SWO.
h. Измените Reset type тип сброса software to system reset (resets the core and peripherals) 

с программного на сброс системы (сбрасывает ядро и периферийные устройства).
Примечание. В этом примере по умолчанию используется программный сброс, по-

скольку он был разработан со старой версией IDE, которая содержит некоторые 
ограничения со сбросом системы.

i. Перейдите на вкладку Multicore, чтобы включить общий режим, установив 
флажок Включить многоядерную отладку Enable multicore debugging / shared mode. 

3.1.3 Загрузка и отладка обоих проектов (EWARM)
Перед загрузкой проекта подключитесь к плате NUCLEO-WL55JC:
• Подключите инструмент программирования и отладки STLINK-V3E к плате 

NUCLEO-WL55JC.
• Подключите кабель USB к разъему CN1 USB STLINK на плате.
• LED6 горит красным при подключении ST-LINK.
1. Загрузите проект Templates_CM4 и запустите сеанс отладки, нажав кнопку 

загрузки и отладки.
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Примечание: эта цифра не является контрактной.

2. Выполняйте код до тех пор, пока не появится инструкция, устанавливающая 
C2BOOT (см. Рисунок ниже). Этот проект загружает Cortex-M0 +, устанавливая 
бит C2BOOT в PWR_CR4.
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3.2 Известные ограничения (EWARM)
• При использовании опции сброса программного обеспечения в первый раз 

для загрузки с Cortex-M0 + (флэш-память пуста) загрузка выполняется успешно, 
но на протяжении всего сеанса отладки отображается сообщение HardFault.

• Параметр сброса системы не работает в сеансе отладки: при применении 
сброса системы из сеанса отладки генерируется ошибка HardFault.

4 Использование MDK-ARM
MDK-ARM (от Keil) по умолчанию устанавливается в каталог C: \ Keil: про-

грамма установки создает ярлык μVision® 5 в меню «Пуск».
В этом разделе используется MDK-ARM v5.32 с внутренним пакетом для 

STM32WL5x (Keil.STM32WLxx_DFP.1.0.8) и шаблон проекта из STM32Cube_FW_
WL_V1.0.0.

Примечание: все необходимые пакеты доступны для загрузки с официального веб-
сайта Arm Keil.

4.1 Шаги отладки двухядерных микроконтроллеров (MDK-ARM)

4.1.1 Настройки проекта CM4 (MDK-ARM)
В этом разделе описаны настройки проекта CM4 и используется шаблон про-

екта из STM32Cube_FW_WL_V1.0.0 с именем Templates_CM4.
1. Откройте проект Template DualCore в

\ STM32Cube_FW_WL_V1.0.0 \ Проекты \ NUCLEO-WL55JC \ Templates \ DualCore \ MDK-ARM.
Этот проект используется для одновременной работы с обоими ядрами. Этот 

проект теперь отображается в представлении Project Explorer, как показано на ри-
сунке ниже. 

2. Установите проект Templates_CM4 как активный и убедитесь, что настройки 
совместимы с параметрами, указанными ниже.

a. Выберите правильное устройство, открыв окно конфигурации и выбрав: 
Project -> Options for Target -> Device устройство STM32WL55JCIx: CM4 из списка. 

b. В разделе Project -> Options for Target -> Target -> Read / Only Memory Areas 
убедитесь, что выбрана правильная область памяти: загрузка из основной флэш-
памяти по адресу 0x0800 0000 и загрузка из памяти SRAM1 по адресу 0x2000 0000.

c. Выберите ST-LINK Debugger в качестве отладчика из Project -> Options for 
Target -> Debug.

Плата NUCLEO-WL55JC содержит встроенный отладчик ST-LINK V3.
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d. Перейдите в Debugger -> Settings и убедитесь, что отладчик подключен, как по-
казано на рисунке ниже.

е. Включите двухъядерную отладку, установив флажок Shareable ST-Link, что-
бы иметь возможность отлаживать оба ядра одновременно.

Примечание. Чтобы настроить многоядерную отладку с помощью зонда отладки 
ST-LINK, установите последнюю версию сервера ST-LINK.

f. Выберите порт доступа (порт 0 для Cortex-M4).
g. Выберите интерфейс связи как SWD, чтобы использовать канал связи после-

довательного вывода (SWO) (меньше контактов, чем JTAG).
h. Выберите параметры подключения и сброса.
- Connect under reset сохраняет активным сигнал аппаратного сброса (HW 

RESET) при подключении к устройству.
- HW RESET выполняет аппаратный сброс путем подачи сигнала аппаратного 

сброса (HW RESET).
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i. Выберите параметры загрузки.
- Проверка загрузки кода останавливает ЦП после выполнения текущей ин-

струкции.
- Download to Flash загружает код во всю область памяти.
j. Из окна загрузки Flash, показанного на рисунке ниже:
- Функция загрузки используется для настройки операций Flash.
- RAM for Algorithm определяет адресное пространство, в котором загружаются 

и выполняются алгоритмы программирования. Обычно адресное пространство 
находится во встроенной оперативной памяти.

- Программный алгоритм содержит определения для программирования 
флэш-памяти.

4.1.2 Настройки проекта CM0 + (MDK-ARM)
В этом разделе описаны настройки проекта CM0 + и используется шаблон про-

екта из STM32Cube_FW_WL_V1.0.0 с именем Templates_CM0PLUS.
1. Откройте проект Templates_CM0PLUS в другом экземпляре и убедитесь, что на-

стройки совместимы с параметрами, указанными ниже.
а. Перейдите в Project -> Options for Target ‘Templates_CM0PLUS’
б. Выберите правильное устройство, открыв окно конфигурации и выбрав
Project -> Options for Target -> Device, затем выберите устройство STM32WL55JCIx: 

CM0P из списка.
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c. В разделе Project -> Options for Target -> Target -> Read / Only Memory Areas убедитесь, 
что выбрана правильная область памяти: загрузка из основной флэш-памяти по 
адресу 0x0802 0000 и загрузка из памяти SRAM1 по адресу 0x2000 4000

d. Перейдите в Debugger -> Settings и убедитесь, что отладчик подключен, как по-
казано на рисунке ниже.

е. Включите двухъядерную отладку, установив флажок Shareable ST-Link, чтобы 
иметь возможность отлаживать оба ядра одновременно.

f. Выберите порт доступа (порт 1 для Cortex-M0 +).
g. Выберите интерфейс связи как SWD, чтобы использовать канал связи после-

довательного вывода (SWO) (меньше контактов, чем JTAG).
h. Выберите параметры подключения и сброса.
- Connect Normal останавливает CPU на выполняемой в данный момент инструк-

ции после подключения.
- SYSRESETREQ выполняет программный сброс, устанавливая бит SYSRESETREQ. 

Ядро Cortex-M0 + и периферийные устройства на кристалле сбрасываются (един-
ственный режим сброса, поддерживаемый Cortex-M0 +).

i. Выберите параметры загрузки.
- Проверка загрузки кода останавливает ЦП после выполнения текущей ин-

струкции.
- Download to Flash загружает код во всю область памяти.
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j. Из окна загрузки Flash, показанного на рисунке ниже:
- Функция загрузки используется для настройки операций Flash.
- RAM for Algorithm определяет адресное пространство, в котором загружаются 

и выполняются алгоритмы программирования. Обычно адресное пространство 
находится во встроенной оперативной памяти.

- Алгоритм программы содержит определения для программирования флэш-
памяти.

4.1.3 Загрузка и отладка обоих проектов (MDK-ARM)
Перед загрузкой проекта подключитесь к плате NUCLEO-WL55JC (см. Рису-

нок 13)
• Подключите инструмент программирования и отладки STLINK-V3E к плате 

NUCLEO-WL55JC.
• Подключите кабель USB к разъему CN1 USB STLINK на плате.
• LED6 горит красным при подключении ST-LINK
1. Скомпилируйте и загрузите проект templates_CM4, используя кнопку Build 

and Load (Создать и загрузить).
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2. Запустите сеанс отладки, затем выполняйте приложение до тех пор, пока не 
появится инструкция, устанавливающая C2BOOT (см. Рисунок ниже). Этот про-
ект загружает Cortex-M0 +, устанавливая бит C2BOOT в PWR_CR4.

3. Соберите и загрузите проект Templates_CM0PLUS.
4. Запустите сеанс отладки.
Примечание: 
• Подключение к двум ядрам одновременно в режиме совместного использо-

вания возможно только в том случае, если опция ”Stop after Reset” (Остановить 
после сброса) отключена, чтобы гарантировать, что C2BOOT не сбрасывается. 
Cortex-M0 загружается только после того, как Cortex-M4 установил C2BOOT в 
PWR_CR4.

• Возможно подключение к каждому ядру отдельно (без режима совместного 
использования), но бит C2BOOT должен быть установлен перед подключением к 
Cortex-M0 +



Getting started with STM32WL5x MCUs using IAR Embedded Workbench® and MDK-ARM	 AN5556

5 Отладка и программирование сценариев
использования с EWARM и MDK-ARM

В этом разделе подробно описывается конкретный вариант использования, 
описывая поддержку устройств STM32WL5x в EWARM и MDK ‑ ARM.

5.1 Как подключить и загрузить приложение Cortex-M0 +, когда вся 
флэш-память пуста (EWARM)

Важно: перед подключением к ядру Cortex-M0 + убедитесь, что бит C2BOOT в 
PWR_CR4 включен.

С помощью следующих шагов можно загрузить приложение Cortex-M0 +, пока 
вся флэш-память пуста.

1. C2BOOT должен быть автоматически установлен перед подключением 
AP1 для шага загрузки путем добавления дополнительной опции --macro_param 
EnableM0PlusCore = 1 из опции Project -> Debugger -> Extra options.

2. Перейдите в Project -> Option -> ST-LINK -> Setup и выберите режим сброса 
в качестве сброса системы.

3. Соберите приложение и выберите  Project -> Download -> Download active application 
(Загрузить активное приложение), чтобы запрограммировать приложение Cortex ‑ 
M0 + во флэш-памяти по адресу 0x0802 0000.
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4. Загрузите активное приложение в целевой объект без запуска полного сеанса 
отладки, используя Project -> Download -> Download active application.

Следующее сообщение об ошибке указывает, что C2BOOT не установлен. При 
необходимости среда IDE пытается подключиться с помощью нескольких попы-
ток, пока не истечет время ожидания в 1 с (для ожидания возможного включения 
C2BOOT из приложения), иначе среда IDE возвращает ошибку, указывающую, 
что точка доступа AP1 недоступна.
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5.2 Как подключить и загрузить приложение Cortex-M0 +, когда вся 
флэш-память пуста (MDK-ARM)

С помощью следующих шагов можно загрузить приложение Cortex-M0 +, пока 
вся флэш-память пуста.

1. C2BOOT должен быть автоматически установлен перед подключением AP1 
для этапа загрузки.

- Подключитесь к AP0 с помощью MDK-ARM (см. Раздел 4.1.1).
- Откройте окно памяти, выбрав  View > Memory.
- Записать 0x0000 8000 в PWR_CR4 (по адресу 0x5800 040C).

2. Перейдите на вкладку Debug и убедитесь, что отладчик подключен, как по-
казано на рисунке 24.

3. Соберите приложение и перейдите в Flash -> Download, чтобы запрограмми-
ровать активное приложение на целевое устройство без запуска полного сеанса 
отладки.

При попытке проделать ту же манипуляцию перед настройкой C2BOOT появ-
ляется сообщение об ошибке, указывающее, что AP1 недоступен.
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6 Безопасное программирование
В этом разделе описываются шаги, необходимые для включения безопасности, 

чтобы защитить области памяти (флэш-память, SRAM1 и SRAM2) от доступа со 
стороны любого неавторизованного мастера шины.

Области SRAM1 и SRAM2 защищены только тогда, когда включена защита 
флэш-памяти (ESE = 1 и FSD = 0).

Безопасная флэш-память
Безопасная область флэш-памяти:
• начинается с базового адреса флэш-памяти + (включенный SFSA [6: 0] x 

0x0800), где SFSA [6: 0] является безопасным стартовым адресом флэш-памяти и 
содержит начальный адрес первой 2-килобайтной страницы защищенной обла-
сти флэш-памяти. .

• заканчивается на последнем адресе флэш-памяти
Примечание. Когда включена защита CPU2, минимальный размер защищенной об-

ласти CPU2 составляет один сектор (2 Кбайта). Например, с защищенной областью 
CPU2 от 0x0802 7000 (включительно) до 0x0803 FFFF (включительно), FLASH_SFR 
должен быть запрограммирован с SFSA = 0x4E.

Флаг ESE в FLASH_OPTR указывает, включена ли защита CPU2. Любой доступ 
CPU1 к области безопасности CPU2 вызывает ошибку флага RDERR или WRPERR.

Безопасная не резервная SRAM1
Безопасная не резервная область SRAM1:
• начинается с небезопасного базового адреса SRAM1 + (SNBRSA [4: 0] x 

0x0400) включен, где SNBRSA [4: 0] - это безопасный начальный адрес небезопас-
ной SRAM1 и содержит начальный адрес первой страницы размером 1 Кбайт без-
опасная не резервная область SRAM1.

• заканчивается на не резервном последнем адресе SRAM1
Например, с защищенной областью SRAM1 CPU2 от 0x2000 6C00 (включи-

тельно) до 0x2000 7FFF (включительно), FLASH_SRRVR должен быть запрограм-
мирован с SNBRSA = 0x1B. Любой доступ на чтение CPU1 возвращает нулевые 
данные. Доступ для записи в защищенную область SRAM1 CPU2 отбрасывается и 
генерирует событие незаконного доступа.

Примечание. Если для NBRSD установлено значение 1, SRAM1 не является защи-
щенным.

Безопасная SRAM2
Безопасная область SRAM2:
• начинается с базового адреса SRAM2 + (включенный SBSRA [4: 0] x 0x0400), 
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где SBSRA [4: 0] - это безопасный начальный адрес SRAM2 и содержит начальный 
адрес первой 1-килобайтной страницы защищенной области SRAM2.

• заканчивается на последнем адресе SRAM2. Например, для защищенной об-
ласти SRAM2 CPU2 от 0x2000 A800 (в комплекте) до 0x2000 FFFF (в комплекте), 
FLASH_SRRVR должен быть запрограммирован с SBSRA = 0x0A. Любой доступ 
на чтение CPU1 возвращает нулевые данные. Доступ на запись в защищенную об-
ласть SRAM2 CPU2 отбрасывается и генерирует событие незаконного доступа.

Примечание. Если для BRSD установлено значение 1, SRAM2 не является защи-
щенным.

Option-byte setup (Установка байт опций)
Перед защитой системы и памяти, как подробно описано в следующих раз-

делах, байты опций должны быть настроены следующим образом с помощью ин-
струмента STM32CubeProgrammer:

• FSD = 0 для включения общей безопасности системы
• SFSA [6: 0] = 0x40 в FLASH_SFR для защиты второй половины области флэш-

памяти.
• SNBRSA [4: 0] = 0x10 и NBRSD = 0 в FLASH_SRRVR для защиты второй по-

ловины нерезервной SRAM1
• SBRSA [4: 0] = 0x10 и BRSD = 0 в FLASH_SRRVR для защиты второй поло-

вины резервной SRAM2



Getting started with STM32WL5x MCUs using IAR Embedded Workbench® and MDK-ARM	 AN5556

6.1 Безопасное программирование с помощью EWARM
Следующие шаги необходимы для выполнения безопасного программирова-

ния с использованием платы NUCLEO_WL55JC и EWARM:
1. Убедитесь, что все байты опций сконфигурированы, как во введении в Раз-

дел 6 «Безопасное программирование».
2. Откройте проект CM4 и убедитесь, что все параметры проекта настроены, 

как описано в Разделе 3.1.1.
3. Откройте проект CM0 + и убедитесь, что все параметры проекта настроены, 

как описано в Разделе 3.1.2.
4. Перейдите в Project options -> Debugger -> Download tab from the CM0+ project и заме-

ните флэш-загрузчик, выбранный FlashSTM32WL_SEC.board, который доступен 
в разделе
C: \ Program Files (x86) \ IAR Systems \ Embedded Workbench 8.4_3 \ arm \ config \ flashload er \ ST.

5. Соберите и загрузите приложение Cortex-M4.
6. Настройте C2BOOT на выполнение загрузки CPU2 (Cortex-M0 +) в PWR_

CR4.
7. Соберите и загрузите приложение Cortex-M0 +: программирование флэш-

памяти выполняется с помощью интерфейса JTAG.
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6.2 Безопасное программирование с использованием MDK-ARM
Следующие шаги необходимы для выполнения безопасного программирова-

ния с использованием платы NUCLEO_WL55JC и MDK-ARM:
1. Убедитесь, что все байты опций настроены, как во введении в Раздел 6.
2. Откройте проект CM4 и убедитесь, что все параметры проекта настроены, 

как описано в Разделе 4.1.1.
3. Откройте проект CM0 + и убедитесь, что все параметры проекта настроены, 

как описано в Разделе 4.1.2.
4. Перейдите в Project options -> Debugger > Flash Download tab и обновите адрес вы-

полнения флэш-загрузчика в ОЗУ для алгоритма, указав безопасный адрес SRAM.
5. Соберите и загрузите приложение Cortex-M4.
6. Настройте C2BOOT на выполнение загрузки CPU2 (Cortex-M0 +) в PWR_

CR4.
7. Соберите и загрузите приложение Cortex-M0 +: программирование флэш-

памяти выполняется с помощью интерфейса JTAG.
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